Ne Yazıkki Yine Türkçe Karakter Sorunu

Eklenti Türkçe tercüme bölümü.

Ne Yazıkki Yine Türkçe Karakter Sorunu

İleti moonlight 23.08.2006, 22:36

http://forum.ceviz.net/showthread.php?t=26966
ALEXIS yazdı:veritabanından olmadığına eminsen, kodları .htaccess adında bir dosya oluşturup içine kopyala sonra da root dizinine yükle.

[syntax="apache"]AddLanguage tr .tr
AddDefaultCharset ISO-8859-9
AddCharset ISO-8859-9 .iso8859-9 .latin9 .trk[/syntax]



LaviortH_cL yazdı:PhpBB ana klasöründe includes/page_header.php ve admin/page_header_admin.php dosyalarını bul ve en başlarına alttaki kodu ekle.

Kod: Tümünü seç
<?php

header ("Content-Type: text/html; charset=iso-8859-9");

?>


emrag yazdı:sitenin dili almanca ve karakter kodlamasıda ona göre. yapman gereken templates/teman/overall_header.tpl içindeki şu satırı bulup

<meta http-equiv="Content-Type" content="text/html; charset=WINDOWS-1254" />


bununla değiştirmek

<meta http-equiv="content-type" content="text/html; charset=iso-8859-9" />

KaRiZMa18 yazdı:üstat aynı sorun bendede oldu sana şunu tavsiye edeyim veritabanını Wordpad de ac

Düzen>Değiştir(CTRL+H) Bunu ac

Aranan : kısmına : ö

Yeni Değer : ö

tümünü değiştir diyip
değiştirebilirsin

Ben 50 mb lık veritabanını öle değiştirdim üstelik garanti oluyo

Kolay Gelsin :D

Bunların hepsini denedim
Anlamdıgım nokta forumun ana dizini normal. Ama içerik ve kullanıcılarda türkçe karakter problemi var.
Hostingimle görüştüm. Onlar phpbb forumlarından destek alın dediler.
Resimlere bakarak sorunumu analayabilirsiniz.
Yardımlarınızı bekliyorum.

ResimResimResimResimResim
En son moonlight tarafından, 31.08.2006, 17:37 tarihinde değiştirildi, toplamda 1 değişiklik yapıldı.
Kullanıcı avatarı
moonlight
Üye
Üye
 
İleti: 160
Kayıt: 25.07.2006, 18:15
Konum: İstanbul

İleti AkrepKral 24.08.2006, 00:17

Aynı garipliğin benzeri bende de var. Yalnız bende site üzerinde sorun yok.
DB yedek aldığımda DB içeriğinin Türkçe karakterden bi haber olduğunu görüyorum.
Aynı DB'yi localhost veya başka sitede kurulu phpbb üzerine yüklüyorum bu kez site üzerinde de Türkçe Karakter sorunu ortaya çıkıyor.
(tabi yüklediğim kadarında)
Bu sorun nasıl aşılır PhpMy Adminden mi Nereden?
.. Akreplerde Ölür ..
http://www.akreportalnet.com
Kullanıcı avatarı
AkrepKral
Üye
Üye
 
İleti: 142
Kayıt: 28.11.2005, 00:13

Cvp: Ne Yazıkki Yine Türkçe Karakter Sorunu

İleti moonlight 24.08.2006, 22:42

Neyse yardımlarınız için sagolun demekki yardımda bir yere kadarmış :P :P :P :-1: :-1: :-1:
Kullanıcı avatarı
moonlight
Üye
Üye
 
İleti: 160
Kayıt: 25.07.2006, 18:15
Konum: İstanbul

İleti

Matmazella
24.08.2006, 23:11

Sistemini, forumunu, veritabanını kurcalamadan daha ileri yardım edilmiyor.

Bu kodu kullandın mı ? ceviz.net ten:


Eğer böyle bir sorun varsa , ki olabilir. şu yolu izleyiniz. Sitenizin veritabanına bağlanan kodunun altına

mysql_query("SET NAMES 'latin5'");
mysql_query("SET CHARACTER SET latin5");
mysql_query("SET COLLATION_CONNECTION = 'latin5_turkish_ci'");
Kullanıcı avatarı
Matmazella
Site Yöneticisi
Site Yöneticisi
 
İleti: 2563
Kayıt: 30.06.2005, 09:08

İleti AkrepKral 25.08.2006, 01:50

Bu benim işime de yarayabilir mi acaba? Bende Latin1 olarak geçiyo. Ve nasıl girilir. Mevcut Mysql'a mı yoksa alınan yedeğe mi?
.. Akreplerde Ölür ..
http://www.akreportalnet.com
Kullanıcı avatarı
AkrepKral
Üye
Üye
 
İleti: 142
Kayıt: 28.11.2005, 00:13

İleti purple 25.08.2006, 02:15

O kodu hash den giriceksiniz diyeceğim ama konu çok dağılacak. Bu konuda uzman birisi olarak şunu diyebilirim;
phpmyadmin ile yedek alırsanız bu tarz sorunları yaşamanız normal. Nedeni; host değiştirince önceki hostunuzdan aldığınız yedeğin phpmyadmin versiyonu ile yeni hostunuzun phpmyadmin versiyonun uyuşmaması. Yedeğinizin charset yani karakter seti ile yeni phpmyadmin'deki charset ayarlarının farklı oluşu.
Ne öneririm?
Aldığınız yedeğin charseti ne ise yeni phpmyadmin ayarlarınızda da aynı charseti ayarlayın ve import ederken bigdump kullanın. Saygılar.
Kullanıcı avatarı
purple
Üye
Üye
 
İleti: 618
Kayıt: 06.03.2006, 22:40

İleti AkrepKral 25.08.2006, 02:44

Sorun o değil. İlk defa böyle bir şeyle karşılaştım. Garip bir şey. Hostlar arası sorun yok daha doğrusu öyle bir sorunu yaşamama gerek kalmıyor.
Şu an ki mevcut Hostta Aldığım Yedekte Sorun var. Yani herhangi bir yere yükleme yapmıyorum. Şu an ki hostta Php My Adminden Zaten yeden alınamıyor.
Yüklemenin sonlarına doğru "Yüklenemedi" deyip kapanıyor. Bende C Panel Üzerindeki Backup-Yedekleme- den alıyorum DB yedeğini.

Winrar veya EditPlas ile açıyorum. Plus Üzerinde normal olan karakterler Yedek İçinde yoklar. Türkçe karekterler ascii çıkıyor.
.. Akreplerde Ölür ..
http://www.akreportalnet.com
Kullanıcı avatarı
AkrepKral
Üye
Üye
 
İleti: 142
Kayıt: 28.11.2005, 00:13

İleti

Matmazella
25.08.2006, 04:34

cpanel üzerinden full backup alıyorsun, bunu sadece yine cpanelden backup import ile yazabilirsin, phpMyadminde çalışmaması normal.
Kullanıcı avatarı
Matmazella
Site Yöneticisi
Site Yöneticisi
 
İleti: 2563
Kayıt: 30.06.2005, 09:08

İleti moonlight 25.08.2006, 13:16

Öncelikle cevaplarınız için teşekkürler. Hiç ilgilenmediginizi düşünmeye başlamıştım.. :roll:
Eğer böyle bir sorun varsa , ki olabilir. şu yolu izleyiniz. Sitenizin veritabanına bağlanan kodunun altına

mysql_query("SET NAMES 'latin5'");
mysql_query("SET CHARACTER SET latin5");
mysql_query("SET COLLATION_CONNECTION = 'latin5_turkish_ci'");

Bunu daha önce denemiştim.Bunu yapınca aşagıdaki hatayı alıyorum.
Resim
purple yazdı:O kodu hash den giriceksiniz diyeceğim ama konu çok dağılacak. Bu konuda uzman birisi olarak şunu diyebilirim;
phpmyadmin ile yedek alırsanız bu tarz sorunları yaşamanız normal. Nedeni; host değiştirince önceki hostunuzdan aldığınız yedeğin phpmyadmin versiyonu ile yeni hostunuzun phpmyadmin versiyonun uyuşmaması. Yedeğinizin charset yani karakter seti ile yeni phpmyadmin'deki charset ayarlarının farklı oluşu.
Ne öneririm?
Aldığınız yedeğin charseti ne ise yeni phpmyadmin ayarlarınızda da aynı charseti ayarlayın ve import ederken bigdump kullanın. Saygılar.

Purple arkadaşımın dedigi çok dogru. Yedegi phpmyadimnden almıştım. Acpden yedek alınmıyordu siteden.Bigdumpla bir kez daha deneyim.
Kullanıcı avatarı
moonlight
Üye
Üye
 
İleti: 160
Kayıt: 25.07.2006, 18:15
Konum: İstanbul

İleti AkrepKral 25.08.2006, 14:14

ALEXIS yazdı:cpanel üzerinden full backup alıyorsun, bunu sadece yine cpanelden backup import ile yazabilirsin, phpMyadminde çalışmaması normal.


Full Backup'tan kastın tüm sitenin yedeği mi bilmiyorum Alexis. Ama C paneldeki Veritabanlarını gösteren yerden Kullandığın Veritabanının yedeğini alıyorum. Full Backup tüm sitenin yedeğini almaz mı. Veritabanları için Full Backup diye bir seçenek yok.
.. Akreplerde Ölür ..
http://www.akreportalnet.com
Kullanıcı avatarı
AkrepKral
Üye
Üye
 
İleti: 142
Kayıt: 28.11.2005, 00:13

Cvp: Ne Yazıkki Yine Türkçe Karakter Sorunu

İleti moonlight 25.08.2006, 15:26

Evet sonunda yaptım. 10 günlük ugraş sonunda bigdump yöntemiyle sonunda sorun halloldu.:D :D :D Bu yöntemi daha önce denemiştim ama olmamıştı. Ama purple dedigi gibi mysql karakter setini kendiminkisinde olan latin1_bin yaptım ve oldu.
Purple sonsuz teşekkürler.. :wink: :wink: :wink:
Kullanıcı avatarı
moonlight
Üye
Üye
 
İleti: 160
Kayıt: 25.07.2006, 18:15
Konum: İstanbul

İleti EFE03 13.09.2006, 09:39

bigdump ??
EFE03
Üye
Üye
 
İleti: 302
Kayıt: 09.06.2006, 07:37

İleti

Matmazella
13.09.2006, 09:46

İlk mesajda yazan yöntemler ve mysql_query("SET NAMES 'latin5'"); işe yaramıyor. her iki karakter setini aynı yaptığımı sanıyorum, yine bozuk yine bozuk.

Ben 8 saattir uğraşıyorum. Bi ton dosya down/up ettim, mysql e geldi sıra.. foşşşş :scared:
Kullanıcı avatarı
Matmazella
Site Yöneticisi
Site Yöneticisi
 
İleti: 2563
Kayıt: 30.06.2005, 09:08

İleti

Matmazella
13.09.2006, 10:50

hımmm, şöyle açıklayayım, phpmyadmin sürümleri alakalı olduğunu bizzat test ettim, almak hatalı, vermek kolay.

navicat ile aldım verileri, bigdump ile yazdım, sorun çıkmadı.
Kullanıcı avatarı
Matmazella
Site Yöneticisi
Site Yöneticisi
 
İleti: 2563
Kayıt: 30.06.2005, 09:08

Cvp: Ne Yazıkki Yine Türkçe Karakter Sorunu

İleti ararat 29.10.2006, 18:24

Evet Hepsini okudumama ben aradığım Cevabı bulamadım Ben Şu anda Phpmyadmin de kurulu olan datebaseyi var olan latin1_swedish_ci yi yine phpmyadminden latin5_turkish_ci boyler bişey Mumkunmu acaba Bilen Varmı
Ve ya Şoyle bir Şey gibi olurmu acaba bişey Ama
UPDATE ALTER DATABASE `db_adıdb` DEFAULT CHARACTER SET latin5 COLLATE latin5_turkish_ci;

Db Kaldımadan yapmak istiyorum
ararat
Üye
Üye
 
İleti: 5
Kayıt: 21.03.2006, 22:05

İleti moonlight 29.10.2006, 23:42

bigdump yöntemini dene arkadaşım kesin çözüm...
Kullanıcı avatarı
moonlight
Üye
Üye
 
İleti: 160
Kayıt: 25.07.2006, 18:15
Konum: İstanbul

Cvp: Ne Yazıkki Yine Türkçe Karakter Sorunu

İleti l3LooD 30.10.2006, 22:22

arkadaslar , sunucumu degiştirdim. MySQL 4.1.18 kullanan bi sunucudan verileri aldım.ve yeni MySQL 4.1.20 sunucuma yukledim ama turkçe karakter sorunu verdi.anlatılan hepsini denedim ama fayda yok.
sql imin içeriği aşagıdaki gibi bu normalmi : arkadaslar msn den yardım edebilejek varsa msn adresim : seboist57@hotmail.com
Resim
l3LooD
Üye
Üye
 
İleti: 17
Kayıt: 02.05.2006, 19:32

Cvp: Ne Yazıkki Yine Türkçe Karakter Sorunu

İleti cemoka 11.12.2006, 11:14

phpMyAdmin kullanarak aldığınız yedek dosyasında tablo yaratılmasında kullanılan sqllerdeki
TYPE=MyISAM ifadesini ENGINE=MyISAM DEFAULT CHARSET=latin5 (veya utf8) ifadesi ile değiştirip tabloları tekrar yaratırsanız veritabanında herhangi bir sorun kalmıyor. örneğin:

CREATE TABLE `phpbb_config` (
`config_name` varchar(255) NOT NULL default '',
`config_value` varchar(255) NOT NULL default '',
PRIMARY KEY (`config_name`)
) TYPE=MyISAM;

ifadesi yerine

CREATE TABLE `phpbb_config` (
`config_name` varchar(255) NOT NULL default '',
`config_value` varchar(255) NOT NULL default '',
PRIMARY KEY (`config_name`)
) ENGINE=MyISAM DEFAULT CHARSET=latin5;

Veritabanında doğru hale getirildikten sonra da includes/db.php dosyasında

// Make the database connection.
$db = new sql_db($dbhost, $dbuser, $dbpasswd, $dbname, false);

satırlarının altına

mysql_query("SET NAMES 'latin5'"); //hangi dil kodlaması ise onu yazıyorsunuz "utf8" vb

satırını eklemeniz yeterli oluyor.
cemoka
Üye
Üye
 
İleti: 6
Kayıt: 16.12.2005, 14:44

İleti Cybernet 17.12.2006, 20:10

bende aynı sorunla karşılaşmıştım. bigdump ın son sürümünü adresinden indirip içindeki ayarları yaparken dil seçeneği bölümüne kendi dilinizi yazıp sonraki dil seçeneğine utf8 yazın. buradaki kodda şunu ifade ediyor: yedekteki dil uyumsuz ise utf8 dil seçeneğini kullanarak işle. bunu yaptıktan sonra sorununuz kalmayacaktır. yanlız yedeklerinizin düzgün olarak aldığınıza emin olun.
Kullanıcı avatarı
Cybernet
Üye
Üye
 
İleti: 44
Kayıt: 20.01.2006, 21:31
Konum: Rize

Cvp: Ne Yazıkki Yine Türkçe Karakter Sorunu

İleti MillStory 25.12.2006, 01:24

Bende aynı sorunla bayağı uğraştım ama çözümü buldum.
Buraya adım adım yazıyorum eğer yeterli olmazsa resimli bir anlatımda yapabilirim.

Öncelikle eski veritabanımızın yedeğini iki ayrı şekilde yapı ve veri olarak alıyoruz.
Daha sonra yeni phpmyadmin'de bir veritabanı oluşturup aldığımız yapısal yedeği yüklüyoruz.
Böylece tüm tablolarımız oluşmuş oluyor.
Daha sonra veriyedeğini ve bigdump.php dosyasını ftp ile serverımızın root dizinine atıyoruz.
bigdump.php dosyasında veritabanı adı kullanıcı adı şifresi ve yüklenecek yedeğin ismini gerekli yerlere yazdıktan sonra www.benimsitem.com/bigdump.php isimli sayfayı çağırıyoruz.O sayfada alınacak yedeğin ismi göründükten sonra işlemi başlatıyoruz.
Bu kadar basit :)
Anlamayan takılan yapamayan herkese yardımcı olmaya çalışırım ...
Kullanıcı avatarı
MillStory
Üye
Üye
 
İleti: 78
Kayıt: 09.11.2005, 00:47
Konum: Yurt Dışı

Sonraki

Türkçe Desteği



Kimler çevrimiçi

Bu forumu görüntüleyenler: Kayıtlı kullanıcı yok ve 0 misafir