phpBB 2.0.19 Yayınlandı

Yeni sürümler, phpBB duyuruları.

phpBB 2.0.19 Yayınlandı

İleti yigini 30.12.2005, 16:44

Merhaba;
phpBB Yeni Yıl Hediyesini Duyurdu :lol: Bu Sürümde birçok küçük açık ve yalnız IE de ortaya çıkan güvenlik açıkları kapatıldı.Ek olarak birkaç küçük değişiklik eklendi. Yanısıra güvenlik amaçlı en fazla giriş yapma denemesi sayısı eklendi. Bu şekilde şifre saldırılarından korunma kolaylaştı.

Neler Değişti/Eklendi?

[Düzeltme] MS SQL için Session Düzeltmesi

[Düzeltme] Backup'a Oturum Anahtarları Eklendi?

[Düzeltme] Silinen Kullanıcıların Oturum Anahtarlarıda Silinecek

[Düzeltme] MySQL 5 için Destek Sağlandı

[Düzeltme] Admin Sol Menüde Olası Hatalara Sebep Olacak Hatalar Düzeltildi.

[Düzeltme] Kayıtta Kullanıcı Adı Uzunluğu Değişikliği

[Düzeltme] admin_users.php'de Yanlış Yol Düzeltildi. (Bug #667)

[Değişiklik] Versiyon Bilgisi Değişikliği (Yönetim Paneli)

[Güvenlik] XSS Düzeltmesi. URL BBcode için.

[Güvenlik] XSS Düzeltmesi. html açıkken ve Yalnızca IE de güvenlik sorunu yaratabilecek düzeltme Yapıldı.

[Güvenlik] Giriş Denemesi Sayısı Sınırı Kontrolü Getirildi



Resmi Açıklama:
http://www.phpbb.com/phpBB/viewtopic.php?t=352966
En son yigini tarafından, 30.12.2005, 19:29 tarihinde değiştirildi, toplamda 4 değişiklik yapıldı.
Kullanıcı avatarı
yigini
Üye
Üye
 
İleti: 661
Kayıt: 05.10.2005, 16:25

İleti yigini 30.12.2005, 16:54

Yeni 2.0.19 Tam Sürüm Sıfır Kurulum İçin: http://www.phpbb.com/downloads.php

Kod Değişiklikleri İçin: http://www.canver.net/kod-degisiklikler ... t1998.html
Kullanıcı avatarı
yigini
Üye
Üye
 
İleti: 661
Kayıt: 05.10.2005, 16:25

Cvp: phpBB 2.0.19 Yayınlandı

İleti gUngoR 30.12.2005, 17:02

Arkadaslar ben bunu yukledim ve daha sonra admin panele girdim ama bence siz yeni bir dil dosyasi cikarmaniz lazim. Admin panelinde ayarlar'da 2 tane yer var ama yazi yok. Yani yeni satirlar eklenmis. Burada download ettigim dil dosyasini yukledim ve hala goremedim bence sizin dil dosyasindada eklemeler yapmaniz gerek !!

Selametle..
Kullanıcı avatarı
gUngoR
Üye
Üye
 
İleti: 25
Kayıt: 10.11.2005, 21:51

İleti

Matmazella
30.12.2005, 18:29

PhpBB 2.0.19'da Gereken Çeviriler
http://www.canver.net/phpbb-2019da-gere ... .html#8429
Kullanıcı avatarı
Matmazella
Site Yöneticisi
Site Yöneticisi
 
İleti: 2563
Kayıt: 30.06.2005, 09:08

İleti gökhan 31.12.2005, 01:09

forum bitiriyoruz yenisi çıkıyor phpbb hiç unutulmayacak sanırım sürekli ilgi istiyor :)
Kullanıcı avatarı
gökhan
Üye
Üye
 
İleti: 118
Kayıt: 08.10.2005, 16:14

İleti Curtis 31.12.2005, 16:23

Bu başlığı görmeden bende aynen Acyd'in mesajını çevirdim :);

"Herkese Merhaba,

phpBB Grubu olarak phpBB 2.0.19'un çıkışını tüm kullanıcılara duyururuz, bu "hepinize iyi seneler" duyurusuda olabilir. Bu sürümün çıkışında Internet Explorer ile yaşanan sorunlar rolü büyük. Yeni olarak ise siz yöneticilerin panonuzdaki oturum açma sayılarını değiştirmenizi sağladık. Yönetici bu özelliğin ayarını iki yönden yapabilecek, kullanıcının maksimum yanlış şifre girme hakkı ve oturum açtıktan bir süre sonra, siteye kayıtsız kalması durumunda kullanıcının, otomatik olarak oturumunun kapatılması. Bu özellik ile phpBB'nin güvenliğinin artcağını düşünüyoruz.

Her sürümü çıkardığımızda da belirttiğimiz gibi, phpBB'nizi son sürüme güncellemenizi tavsiye ediyoruz. Güncellemek için gerekli paketi phpBB.com'un Dosyalar bölümünde bulabilirsiniz.


Tam Sürüm
Tüm phpBB dosyalarının yanı sıra İngilizce dil dosyasını içerir

Sadece Değiştirilmiş Dosyalar
Eski sürümlerden yeni sürüme güncellemek için değiştirilmiş gerekli dosyaları içerir.

Kod Değişiklikleri
Fazla mod içeren siteler için hazırlanan döküman


Sizin için en kullanışlı paketi seçin.

Tüm paketlerdeki INSTALL ve README dosyalarını okumayı ihmal etmeyin, bu dosyalar docs/ dizinin içinde bulunuyor.


Güncellemenin tüm gerekliliklerini yapmanız önemli, örneğin SQL kodları gibi.


Yeni sürümde tam olarak ne değitşti?

Yeni sürümün içerdiği değişiklikler aşağıdadır:


[Çözüldü] MS SQL'deki sessions tablosundaki index problemi

[Çözüldü] yedekleme için sessions key tablosu eklendi

[Çözüldü] kullanıcıyı silerken veritabanından sessions keyi silme

[Çözüldü] MySQL 5.0'i desteklemek için değişiklikler

[Çözüldü] yönetim menüsünü oluştururken çıkan hatalar

[Çözüldü] kullanıcı adının usercp_register.php' uzaması - BFUK

[Çözüldü] kullanıcı avatarlarına yanlış uzantı adresi - admin_users.php (Bug #667)

[Çözüldü] zlib özelliğini açamayanlar için hata giderildi

[Change] Sürüm bilgisi yönetim panelinde kimler çevirimiçinin altına eklendi

[Güvenlik] XSS olayı (sadece Internet Explorer için) url bbcode için düzeltildi

[Güvenlik] XSS olayı (sadece Internet Explorer için) html özelliğinin açılımı durumunda düzeltildi

[Güvenlik] güvenlik iç.in maksimum şifre giriş hata sayısı eklendi"
Kullanıcı avatarı
Curtis
Üye
Üye
 
İleti: 686
Kayıt: 06.10.2005, 06:22
Konum: İstanbul

Çok Önemli! - phpBB 2.0.19 Genel Bir Hata Var ! ! !

İleti NucLeaR_NS 31.12.2005, 17:49

Selamlar,

Arkdaşlar bu phpBB 2.0.19'u localhostta tertemiz bir şekilde kurdum, KESİNLİKLE hiçbir degişiklik yapmadım phpBB üzerinde olduğu gibi www.phpbb.com'dan indirdiğim haliyle kurdum! ancak şu hataları gözledim bu kesin olan bir hata bence ve ÇOK önemli!

1-Hiç ellemeden forumu üye olun başka bir kullanıcı adı ile "Register" yani ve görün! şu hatayı verecektir!

-----
EDİT BU BENDEN KAYNAKLI GALİBA NEDEN BİLMİYORUM PARDON AMA 2.0.18 i yükleyince görsel dogrulama düzeldi...
------

*******************************************

2-Siteye giriş yapıp, yönetim panelinden üyelik görsel doğrulamayı etkinleştirin ve yeniden başka bir kullanıcı adı ile üye olmayı deneyin!

---
a- Üyelik kodları hep şu biçimlerde ve beyaz arka plan renginden çıkıyor (333333 yada HHHHHH yada LLLLLL yada 999999) ve ÇOK net bir şekilde okunuyor bildigim doğrumu bilmem ama bu kodları bu şekilde okuyan programlar var(mış)

b- görsel dogruma kodunu istediiğiniz kadar doğru girin ölsede kabul etmeyecektir, mesela 666666 kodu var diyelim siz 666666 girerseniz kabul etmez!!! 6 olarak girerseniz kabul eder zaten ondan sonrada üye olmuş oluyorsunuz

********************************************

Hata bunlar arkdaşlar isteyen test edebilir!
En son NucLeaR_NS tarafından, 31.12.2005, 18:09 tarihinde değiştirildi, toplamda 1 değişiklik yapıldı.
NucLeaR_NS
Üye
Üye
 
İleti: 8
Kayıt: 24.12.2005, 02:02

Cvp: phpBB 2.0.19 Yayınlandı

İleti sultan 31.12.2005, 17:59

Dostlar bu phpbb 2.19 da daha önce kurduğumuz klasik 2.18 modları çalışıyormu. 2.18 modlarını 2.19 a yükleyebiliyormuyuz?Değişiklik gerekiyormu? :?
Kullanıcı avatarı
sultan
Üye
Üye
 
İleti: 21
Kayıt: 03.12.2005, 23:54

Cvp: phpBB 2.0.19 Yayınlandı

İleti Ares 31.12.2005, 18:19

sultan yazdı:Dostlar bu phpbb 2.19 da daha önce kurduğumuz klasik 2.18 modları çalışıyormu. 2.18 modlarını 2.19 a yükleyebiliyormuyuz?Değişiklik gerekiyormu? :?


Evet Calisir,
Sende phpBB 2.18 var ise;

http://www.phpbbturkiye.com/2018-den-20 ... t1998.html

Buradaki kod degisikliklerini yapmalisin.

txt olarakda kod degisikligi asagidaki linkde.

http://prdownloads.sourceforge.net/phpb ... hanges.zip
Ares
Üye
Üye
 
İleti: 285
Kayıt: 12.11.2005, 22:52
Konum: Yurt Dışı

Cvp: phpBB 2.0.19 Yayınlandı

İleti sultan 31.12.2005, 20:38

teşekkürler ares ancak emin olamadım ben şu an sitemi sıfırdan 2.19 olarak kuracağım.Ve direk modları yükleyebilirmiyim.Yani 2.18 üzerine 2.19 güncellemesi yapmayacağım.
Kullanıcı avatarı
sultan
Üye
Üye
 
İleti: 21
Kayıt: 03.12.2005, 23:54

İleti gökhan 01.01.2006, 20:41

arkadaşlar 2.19 farklı bir phpbb değil olanın acıkları giderilmiş hali ve güvenlik eklenmiş hali yani 2.18 de ne yapıyorsanız aynısını 2.19 da yapabilirsiniz yani modların ve direk modları kurabilirsiniz.
Kullanıcı avatarı
gökhan
Üye
Üye
 
İleti: 118
Kayıt: 08.10.2005, 16:14

İleti fatihbaz 14.01.2006, 21:16

arkadaşlar bende 2.17 var.2.19 a geçmeden önce 18i yüklemem gerekiyor degil mi?yani direk 19 a geçemiyorum 17den herhalde.bide bu güncelleme sırasında sitedeki herhangi bişey kaybı oluyormu?yani 19a geçelim derken 17 den vede forumdan olmam inşallah.
Kullanıcı avatarı
fatihbaz
Üye
Üye
 
İleti: 870
Kayıt: 25.11.2005, 12:26
Konum: Kahramanmaraş

İleti Curtis 15.01.2006, 00:10

Evet, teker teker..
Kullanıcı avatarı
Curtis
Üye
Üye
 
İleti: 686
Kayıt: 06.10.2005, 06:22
Konum: İstanbul

2.0.10

İleti CaDDe7 17.01.2006, 16:55

Arkadaşlar bende PHPBB 2.0.10 sürümü var. Ben bunu en yüksek sürüme nasıl yükseltebilirim? Yani tek tek mi? Yoksa bir paket ile mi? Adres verirseniz sevinirim. Teşekkürler...
Kullanıcı avatarı
CaDDe7
Üye
Üye
 
İleti: 26
Kayıt: 16.01.2006, 10:16
Konum: Ankara

İleti Curtis 17.01.2006, 18:47

Evet, her halde teker teker yapman gerek, sağlıklı bir forumu için şart..
Kullanıcı avatarı
Curtis
Üye
Üye
 
İleti: 686
Kayıt: 06.10.2005, 06:22
Konum: İstanbul

İleti Curtis 17.01.2006, 18:57

Onu bende ilk düşünüp yazdım, sonra karıştırır falan diye, birde, mod yüklüdür...
Kullanıcı avatarı
Curtis
Üye
Üye
 
İleti: 686
Kayıt: 06.10.2005, 06:22
Konum: İstanbul

İleti cemilonline 21.01.2006, 03:17

Arkadaşlar bu sürümleri yükseltmeden yani 2,10 dan yükseltmek yerine Db yedek alsak ve forumu baştan kursak sonrada yedeği atsak bir problem çıkarmı?


Böyle bişeyi tavisiye edermisiniz?
Kullanıcı avatarı
cemilonline
Üye
Üye
 
İleti: 21
Kayıt: 10.11.2005, 02:17

İleti Curtis 21.01.2006, 15:43

Zaten DB'de sorun var, yani onun da güncellenmesi gerekiyor..
Kullanıcı avatarı
Curtis
Üye
Üye
 
İleti: 686
Kayıt: 06.10.2005, 06:22
Konum: İstanbul

Cvp: phpBB 2.0.19 Yayınlandı

İleti karasakal 27.03.2006, 11:19

paylaşım için teşekkürler
karasakal
Üye
Üye
 
İleti: 2
Kayıt: 01.02.2006, 16:32

İleti Burkay1905 27.03.2006, 13:26

Ya plus ı 2.019 üstünemi yüklüyoruz direk ???
Burkay1905
Üye
Üye
 
İleti: 61
Kayıt: 24.03.2006, 19:34

Sonraki

Duyurular



Kimler çevrimiçi

Bu forumu görüntüleyenler: Kayıtlı kullanıcı yok ve 0 misafir

cron